Moderator: Ninjee

Graphical glitches when starting MechCommander Gold on Win7 64bit

test
test

Aug 10, 2013 #1

Hello,

I just wanted to start playing MechCommander after ages again. I have not played it yet on Windows 7 64bit, and I have some trouble to get it to work properly.

I "installed" the game the way it is explained here, that is I copied all the files from the MechCommander Gold ISO and put it in a folder and launched the MCX.exe. The problem is that when I launch the game the colour are all purple etc. like it is in many other old games.

Now I googled for the issue and the only times where this issue gets mentioned they recommend to either turn off desktop design in compatibility options which doesn't do anything, or press ALT+Enter to switch to window mode and then back. The last option solves the issue as long as I stay in window mode, but it appears again when I go back to full screen which shouldn't happen according to the sites where I read the solution, according to them it should stay fixed.

The problem with window mode is that the window is too tiny to play it and you cannot scroll through the map with your mouse. So I cannot play the game this way.

Did anyone else have the same issue and found a solution for it?
Quote
Like
Dislike
Share

Guest
Guest

Aug 11, 2013 #2

I think I know someone who knows how to solve this. I'll ask him tonight.
Quote
Like
Dislike
Share

SMOKE JAGUAR
SMOKE JAGUAR

Aug 11, 2013 #3

Right click on the MCG.EXE file that you use to launch the game in multiplayer, go to compatibility and select RUn IN WINDOWS 98 mode. Then reduce screen resolution slightly on desktop and check if singleplayer works. Thats how I got MCG to fix the graphics problem on Vista 32 bit.

If that doesnt work, try this test:

◦First, right-click at any empty desktop area to bring out the menu, select Screen Resolution and click advance settings.
◦Another windows will be opened, now you need to click monitor tab and leave it open. Run the game.
◦This is strange solution but works with some people.


Compatibility hack works for some people too (I never tried it):

http://static.macuyiko.com/files/w7ddpa ... atcher.zip

◦Extract and run the tools and then select patch.
◦Select your game executable and wait for the patching process begin. The game will be start and terminate immediately as the application tried to grab the process identifier.
◦Note: This tools will not patch your executables, but it will add some entry in registry. No file will be harmed and touched.
Quote
Like
Dislike
Share

Floisaho
Community Member
Community Member
Floisaho
Community Member
Community Member
Joined: Jul 16, 2012

Aug 11, 2013 #4

Hi,
you can try this:

1.Go to your MCX directory (e.g. C:\Program Files\MCX\).
2.Open prefs.cfg (located in the root directory of your installation) in a text editor.
3.One the line before “FITend” add the following:
l Resolution=3

It should look like this:

White Power Bro!
Quote
Like
Dislike
Share

Floisaho
Community Member
Community Member
Floisaho
Community Member
Community Member
Joined: Jul 16, 2012

Aug 11, 2013 #5

When I tried the above suggestion it made me crash in game, but once I changed Resolution=3 to Resolution=2 it worked fine.
White Power Bro!
Quote
Like
Dislike
Share

Test
Test

Aug 12, 2013 #6

I tried out all of your solutions, sadly none of them worked for me :/

I will try out next now to put it on a virtual machine. I will tell if it works when I have done it.
Quote
Like
Dislike
Share

Danny P
Danny P

Aug 12, 2013 #7

Hit alt enter twice
Quote
Like
Dislike
Share

Smoke_Jaguar
Scout Member
Scout Member
Joined: May 08, 2013

Aug 15, 2013 #8

To OP
ctrl + z fixes brightness and that purple shitznit

@FAKE Smoke_Jaguar: What the fuck wildcat? U posting advice under my name? what, u trying to not sound like a total gay ass nerd FAIL lol
Quote
Like
Dislike
Share

test
test

Aug 15, 2013 #9

@Danny: I wrote that going to window mode and back didn't work for me. The glitches don't exist in window mode, but when I go back to full screen they are back.

@Smoke_Jaguar: Sadly doesn't help either, it just varies the brightness, but not more.


Regarding Virtual Machines, I tried it on Win98 and XP and it works there, but I have some other kind of flickering. I think I will give up on this. Thanks for all who tried to help me anyway though.
Quote
Like
Dislike
Share

Ninjee
Pro
Pro
Joined: Jul 30, 2011

Aug 16, 2013 #10

Danny P wrote:Hit alt enter twice

:D
Last edited by Ninjee on 16:34 - Feb 20, 2014, edited 1 time in total.



Keeping the dream alive!

^_^
Quote
Like
Dislike
Share